Improper Access Control

Affecting moodle/moodle package, versions <3.5.15 || >=3.7.0, <3.7.9 || >=3.8.0, <3.8.6 || >=3.9.0, <3.9.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

moodle/moodle is a learning platform.

Affected versions of this package are vulnerable to Improper Access Control. If the upload course tool in Moodle was used to delete an enrollment method which did not exist or was not already enabled, the tool would erroneously enable that enrollment method. This could lead to unintended users gaining access to the course.

Remediation

Upgrade moodle/moodle to version 3.5.15, 3.7.9, 3.8.6, 3.9.3 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
Víctor Déniz Falcón
CVE
CVE-2020-25701
CWE
CWE-284
Snyk ID
SNYK-PHP-MOODLEMOODLE-1042270
Disclosed
20 Nov, 2020
Published
20 Nov, 2020