Open Redirect

Affecting mediawiki/core package, versions >=0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mediawiki/core is a Free software wiki application developed by the Wikimedia Foundation and others.

Note: This package is not maintained on Packagist anymore, but newer releases exist.

Affected versions of this package are vulnerable to Open Redirect. This happens because it is unable to change visibility of log entries when MediaWiki:Mainpage uses Special:MyLanguage.

Remediation

There is no fixed version for mediawiki/core.

References

CVSS Score

3.1
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
Credit
Unknown
CVE
CVE-2020-35477
CWE
CWE-601
Snyk ID
SNYK-PHP-MEDIAWIKICORE-1053238
Disclosed
18 Dec, 2020
Published
21 Dec, 2020