Improper Input Validation

Affecting mediawiki/core package, versions >=1.31.0, <1.31.6 || >=1.32.0, <1.32.6 || >=1.33.0, <1.33.2 || >=1.33.99, <1.34.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mediawiki/core is a Free software wiki application developed by the Wikimedia Foundation and others.

Note: This package is not maintained on Packagist anymore, but newer releases exist.

Affected versions of this package are vulnerable to Improper Input Validation. MediaWiki allows attackers to bypass the Title_blacklist protection mechanism by starting with an arbitrary title, establishing a non-resolvable redirect for the associated page, and using redirect=1 in the action API when editing that page.

Remediation

Upgrade mediawiki/core to version 1.31.6, 1.32.6, 1.33.2, 1.34.0 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2019-19709
CWE
CWE-20
Snyk ID
SNYK-PHP-MEDIAWIKICORE-1041729
Disclosed
19 Nov, 2020
Published
19 Nov, 2020