Improper Input Validation

Affecting mediawiki/core package, versions >=1.27.0, <1.27.5 || >=1.29.0, <1.29.3 || >=1.30.0, <1.30.1 || >=1.31.0, <1.31.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mediawiki/core is a Free software wiki application developed by the Wikimedia Foundation and others.

Note: This package is not maintained on Packagist anymore, but newer releases exist.

Affected versions of this package are vulnerable to Improper Input Validation. Contrary to the documentation, $wgRateLimits entry for user overrides that for newbie.

Remediation

Upgrade mediawiki/core to version 1.27.5, 1.29.3, 1.30.1, 1.31.1 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2018-0503
CWE
CWE-20
Snyk ID
SNYK-PHP-MEDIAWIKICORE-1041727
Disclosed
19 Nov, 2020
Published
19 Nov, 2020