Cross-site Request Forgery (CSRF)

Affecting magento/community-edition package, versions >=2.1.0, <2.1.18 || >=2.2.0, <2.2.9 || >=2.3.0, <2.3.2

Do your applications use this vulnerable package? Test your applications

Overview

magento/community-edition is a modern cloud eCommerce platform.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). This can result in unintended deletion of user roles.

Remediation

Upgrade magento/community-edition to version 2.1.18, 2.2.9, 2.3.2 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Credit
Djordje Marjanovic
CVE
CVE-2019-7874
CWE
CWE-352
Snyk ID
SNYK-PHP-MAGENTOCOMMUNITYEDITION-458995
Disclosed
02 Aug, 2019
Published
12 Aug, 2019