Improper Input Validation

Affecting livewire/livewire package, versions >=2.2.5, <2.2.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

livewire/livewire is an A front-end framework for Laravel.

Affected versions of this package are vulnerable to Improper Input Validation. $this->validate() usually only returns the validated dataset, however a regression was introduced, that caused it to return ALL data on the Livewire component.

Remediation

Upgrade livewire/livewire to version 2.2.6 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:R
Credit
Unknown
CWE
CWE-20
Snyk ID
SNYK-PHP-LIVEWIRELIVEWIRE-1012444
Disclosed
24 Sep, 2020
Published
24 Sep, 2020