SQL Injection

Affecting doctrine/orm package, versions <2.8.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to SQL Injection. Statements in the Where clause are not wrapped in parenthesis when or or and is written in lowercase.

Remediation

Upgrade doctrine/orm to version 2.8.4 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Unknown
CWE
CWE-89
Snyk ID
SNYK-PHP-DOCTRINEORM-1243727
Disclosed
07 Apr, 2021
Published
07 Apr, 2021