Improper Access Control

Affecting buddypress/buddypress package, versions >=5.0.0, <7.2.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

buddypress/buddypress is a software for online communities, teams, and groups.

Affected versions of this package are vulnerable to Improper Access Control. It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint.

Remediation

Upgrade buddypress/buddypress to version 7.2.1 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Credit
Unknown
CVE
CVE-2021-21389
CWE
CWE-284
Snyk ID
SNYK-PHP-BUDDYPRESSBUDDYPRESS-1729561
Disclosed
06 Oct, 2021
Published
07 Oct, 2021