Improper Input Validation

Affecting webkit2gtk package, versions debian:10: <2.24.1-1 || debian:11: <2.24.1-1 || debian:8: * || debian:9: * || debian:unstable: <2.24.1-1 || ubuntu:16.04: * || ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1 || ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

A validation issue was addressed with improved logic. This issue is fixed in iOS 12.2, tvOS 12.2, watchOS 5.2, Safari 12.1, iTunes 12.9.4 for Windows, iCloud for Windows 7.11. Processing maliciously crafted web content may result in the disclosure of process memory.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
CVE
CVE-2019-7292
CWE
CWE-20
Snyk ID
SNYK-LINUX-WEBKIT2GTK-443179
Disclosed
18 Dec, 2019
Published
12 Apr, 2019