Information Exposure

Affecting webkit2gtk package, versions debian:10: <2.24.1-1 || debian:11: <2.24.1-1 || debian:8: * || debian:9: * || debian:unstable: <2.24.1-1 || ubuntu:16.04: * || ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1 || ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

A cross-origin issue existed with the fetch API. This was addressed with improved input validation. This issue is fixed in iOS 12.2, tvOS 12.2, Safari 12.1, iTunes 12.9.4 for Windows, iCloud for Windows 7.11. Processing maliciously crafted web content may disclose sensitive user information.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
CVE
CVE-2019-8515
CWE
CWE-200
Snyk ID
SNYK-LINUX-WEBKIT2GTK-443164
Disclosed
18 Dec, 2019
Published
12 Apr, 2019