CVE-2019-3888

Affecting undertow package, versions debian:unstable: *

Do your applications use this vulnerable package? Test your applications

Overview

A vulnerability was found in Undertow web server before 2.0.21. An information exposure of plain text credentials through log files because Connectors.executeRootHandler:402 logs the HttpServerExchange object at ERROR level using UndertowLogger.REQUEST_LOGGER.undertowRequestFailed(t, exchange)

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-3888
CWE
CWE-255
Snyk ID
SNYK-LINUX-UNDERTOW-449602
Disclosed
12 Jun, 2019
Published
11 Jun, 2019