RHSA-2019:0766

Affecting mod_auth_mellon package, versions centos:7: <0:0.14.0-2.el7_6.4

high severity
Do your applications use this vulnerable package? Test your applications

Overview

The mod_auth_mellon module for the Apache HTTP Server is an authentication service that implements the SAML 2.0 federation protocol. The module grants access based on the attributes received in assertions generated by an IdP server. Security Fix(es): * mod_auth_mellon: authentication bypass in ECP flow (CVE-2019-3878) * mod_auth_mellon: open redirect in logout url when using URLs with backslashes (CVE-2019-3877) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. Bug Fix(es): * mod_auth_mellon Cert files name wrong when hostname contains a number (fixed in upstream package) (BZ#1697487)

CVE
RHSA-2019:0766
Snyk ID
SNYK-LINUX-MODAUTHMELLON-443479
Published
17 Apr, 2019