Improper Restriction of Operations within the Bounds of a Memory Buffer

Affecting gpac package, versions debian:10: <0.5.2-426-gc5ad4e4+dfsg5-5 || debian:8: <0.5.0+svn5324~dfsg1-1+deb8u3 || debian:9: * || debian:unstable: <0.5.2-426-gc5ad4e4+dfsg5-5 || ubuntu:14.04: * || ubuntu:16.04: * || ubuntu:18.04: *

Do your applications use this vulnerable package? Test your applications

Overview

gf_bin128_parse in utils/os_divers.c in GPAC 0.7.1 has a buffer overflow issue for the crypt feature when encountering a crafted_drm_file.xml file.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2019-11222
CWE
CWE-119
Snyk ID
SNYK-LINUX-GPAC-443314
Disclosed
15 Apr, 2019
Published
13 Apr, 2019