Arbitrary Code Execution

Affecting typescript-tslint-plugin package, versions <1.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

typescript-tslint-plugin is a TypeScript tslint language service plugin

Affected versions of this package are vulnerable to Arbitrary Code Execution. A code execution vulnerability exists in typescript-tslint-plugin due not insufficient restriction when tslint is loaded from the workspace

Remediation

Upgrade typescript-tslint-plugin to version 1.0.0 or higher.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:R
Credit
David Dworken
CVE
CVE-2020-17150
CWE
CWE-94
Snyk ID
SNYK-JS-TYPESCRIPTTSLINTPLUGIN-1056512
Disclosed
07 Jan, 2021
Published
07 Jan, 2021