Cross-site Scripting (XSS)

Affecting tianma-static package, ALL versions

Overview

tianma-static Provides a static file service.

Affected versions of this package are vulnerable to Arbitrary Code Execution via the filename parameter.

Remediation

There is no fix version for tianma-static.

References

Do your applications use this vulnerable package?

CVSS Score

8.0
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    Low
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L
Credit
abdilahrf
CVE
CVE-2018-16474
CWE
CWE-79
Snyk ID
SNYK-JS-TIANMASTATIC-72574
Disclosed
01 Sep, 2018
Published
08 Nov, 2018