Improper Access Control

Affecting strapi package, versions <3.0.0-beta.17.5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

strapi is a HTTP layer sits on top of Koa.

Affected versions of this package are vulnerable to Improper Access Control. It mishandles password resets within packages/strapi-admin/controllers/Auth.js and packages/strapi-plugin-users-permissions/controllers/Auth.js.

Remediation

Upgrade strapi to version 3.0.0-beta.17.5 or higher.

References

CVSS Score

9.8
critical severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P
Credit
brianadeloye
CVE
CVE-2019-18818
CWE
CWE-284
Snyk ID
SNYK-JS-STRAPI-480418
Disclosed
04 Nov, 2019
Published
10 Nov, 2019