Outdated Static Dependency

Affecting ses package, versions <0.6.3

Do your applications use this vulnerable package? Test your applications

Overview

ses is a secure runtime for running third-party code safely.

Affected versions of this package are vulnerable to Outdated Static Dependency. The package relies on realms-shim and has it loaded statically instead of as a dependency that can be updated. The version of realms-shim it has contains multiple critical Sandbox Breakout vulnerabilities.

Remediation

Upgrade ses to version 0.6.3 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CWE
CWE-348
Snyk ID
SNYK-JS-SES-471681
Disclosed
23 Sep, 2019
Published
03 Oct, 2019