Information Exposure

Affecting seneca package, versions <3.9.0

Do your applications use this vulnerable package? Test your applications

Overview

seneca is a Node.js toolkit for Microservice architectures.

Affected versions of this package are vulnerable to Information Exposure. When a process using Seneca crashes, it prints out all of its environment variables.

Remediation

Upgrade seneca to version 3.9.0 or higher.

References

CVSS Score

3.3
low severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Credit
Matteo Collina
CVE
CVE-2019-5483
CWE
CWE-209
Snyk ID
SNYK-JS-SENECA-460597
Disclosed
04 Apr, 2019
Published
03 Sep, 2019