Improper Verification of Signature

Affecting samlify package, versions <2.4.0

Overview

samlify is a Highly configuarable Node.js SAML 2.0 library for Single Sign On.

Affected versions of this package are vulnerable to Improper Verification of Signature. An attacker could potentially wrap the signature of a SAML response, and insert a new username in the original token, making it appear as though a different user was authenticated.

Remediation

Upgrade samlify to version 2.4.0 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Erlend Oftedal
CWE
CWE-91
Snyk ID
SNYK-JS-SAMLIFY-72614
Disclosed
23 May, 2018
Published
15 Nov, 2018