Improper Authorization

Affecting parse-server package, ALL versions

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Improper Authorization. When using the REST api to create a new session token, that tokens is not set as restricted.

Remediation

There is no fixed version for parse-server.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CWE
CWE-285
Snyk ID
SNYK-JS-PARSESERVER-590116
Disclosed
10 Sep, 2020
Published
10 Sep, 2020