Information Exposure

Affecting node-etsy-client package, versions <0.3.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node-etsy-client is a node-etsy-client

Affected versions of this package are vulnerable to Information Exposure. API keys may be disclosed to end users during client error reports.

Remediation

Upgrade node-etsy-client to version 0.3.0 or higher.

References

CVSS Score

7.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:L
Credit
Vandeputte Brice
CVE
CVE-2021-21421
CWE
CWE-200
Snyk ID
SNYK-JS-NODEETSYCLIENT-1090579
Disclosed
04 Apr, 2021
Published
04 Apr, 2021