Malicious Package

Affecting ng-ui-library package, versions >1.0.986 <1.0.988

Do your applications use this vulnerable package? Test your applications

Overview

ng-ui-library is a NBS UI library for angular ng6

Affected versions of this package are vulnerable to Malicious Package. The package contains malicious code that when executed in the browser enumerates password, cvc and cardnumber fields from forms and sends the extracted values to https://js-metrics.com/minjs.php?pl=

Remediation

Upgrade ng-ui-library to version 1.0.988 or higher.

References

CVSS Score

10.0
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Credit
npm security
CWE
CWE-506
Snyk ID
SNYK-JS-NGUILIBRARY-449527
Disclosed
07 Jun, 2019
Published
10 Jun, 2019