Buffer Overflow

Affecting i18next package, versions <19.5.5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

i18next is an internationalization framework for browser or any other javascript environment (eg. node.js).

Affected versions of this package are vulnerable to Buffer Overflow. It is possible to cause buffer overflow by changing the translation to be recursive.

Remediation

Upgrade i18next to version 19.5.5 or higher.

References

CVSS Score

4.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
Credit
lynn
CWE
CWE-119
Snyk ID
SNYK-JS-I18NEXT-575536
Disclosed
09 Jul, 2020
Published
09 Jul, 2020