Path Traversal

Affecting http-file-server package, ALL versions

Do your applications use this vulnerable package? Test your applications

Overview

http-file-server is a Simple HTTP file server.

Affected versions of this package are vulnerable to Path Traversal. The package does not properly sanitize URL paths, allowing an attacker to relatively traverse the filesystem.

Remediation

There is no fixed version for http-file-server.

References

CVSS Score

8.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Credit
toannc123
CVE
CVE-2019-5447
CWE
CWE-23
Snyk ID
SNYK-JS-HTTPFILESERVER-451564
Disclosed
10 Jul, 2019
Published
10 Jul, 2019