Cross-site Scripting (XSS)

Affecting hellojs package, versions <1.18.2

Do your applications use this vulnerable package? Test your applications

Overview

hellojs is a Javascript RESTFUL API library for connecting with OAuth2 services.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) via the state.page_uri query parameter.

Remediation

Upgrade hellojs to version 1.18.2 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N/E:F
Credit
kaykhan
CWE
CWE-79
Snyk ID
SNYK-JS-HELLOJS-540823
Disclosed
07 Jan, 2020
Published
09 Jan, 2020