Timing Attack

Affecting express-basic-auth package, versions <1.1.7

Do your applications use this vulnerable package? Test your applications

Overview

express-basic-auth is a simple plug & play HTTP basic auth middleware for Express.

Affected versions of this package are vulnerable to Timing Attack due to it using native string compare for passwords, as oppose to comparing with a set constant time.

Remediation

Upgrade express-basic-auth to version 1.1.7 or higher.

References

CVSS Score

3.1
low severity
  • Attack Vector
    Adjacent
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Hraban Luyat
CWE
CWE-208
Snyk ID
SNYK-JS-EXPRESSBASICAUTH-174345
Disclosed
01 Mar, 2019
Published
16 Apr, 2019