Information Exposure

Affecting apollo-server-core package, versions <2.4.12

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

apollo-server-core is a core module of the Apollo community GraphQL Server.

Affected versions of this package are vulnerable to Information Exposure. It does not properly enforce validation rules when creating subscription servers, which includes a NoInstrospection rule for the Websocket. This leaks the GraphQL schema types, their relations and human-readable names.

Remediation

Upgrade apollo-server-core to version 2.4.12 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Bitwala security team
CWE
CWE-200
Snyk ID
SNYK-JS-APOLLOSERVERCORE-571663
Disclosed
05 Jun, 2020
Published
07 Jun, 2020