Denial of Service (DoS)

Affecting org.webjars.npm:http-proxy artifact, versions [0,]

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

org.webjars.npm:http-proxy is a HTTP Proxy

Affected versions of this package are vulnerable to Denial of Service (DoS). HTTP requests with long bodies can crash the proxy sever via triggering an ERR_HTTP_HEADERS_SENT unhandled exception.

Note This vulnerability is only viable if proxy server uses the proxyReq.setHeader function to set headers in the proxy request.

PoC by Grant Murphy

A proxy server on http://localhost:3000, using the following curl request will trigger the unhandled exception:

curl -XPOST http://localhost:3000 -d "$(python -c 'print("x"*1025)')"

Remediation

There is no fixed version for org.webjars.npm:http-proxy.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H/E:P/RL:U/RC:C
Credit
Grant Murphy
CWE
CWE-400
Snyk ID
SNYK-JAVA-ORGWEBJARSNPM-569154
Disclosed
14 May, 2020
Published
16 May, 2020