Out-of-bounds Read

Affecting org.webjars.npm:node-sass artifact, versions [,4.4.0)

Do your applications use this vulnerable package? Test your applications

Overview

org.webjars.npm:node-sass is a Node.js bindings to libsass.

Affected versions of this package are vulnerable to Out-of-bounds Read via lexer.hpp. A crafted input will lead to a remote denial of service attack. Note: node-sass is affected by this vulnerability due to its bundled usage of the libsass package.

Remediation

Upgrade org.webjars.npm:node-sass to version 4.4.0 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Credit
Unknown
CVE
CVE-2017-11341
CWE
CWE-79
Snyk ID
SNYK-JAVA-ORGWEBJARSNPM-541161
Disclosed
17 Jul, 2018
Published
08 Jan, 2020