Arbitrary Code Execution

Affecting org.webjars.npm:mathjs artifact, versions (,3.17.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

mathjs is an extensive math library for JavaScript and Node.js

Affected versions of the package are vulnerable to Arbitrary Code Execution. Forbidden properties like constructor could be replaced by using unicode characters when creating an object.

Remediation

Upgrade mathjs to version 3.17.0 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Masato Kinugawa
CVE
CVE-2017-1001003
CWE
CWE-94
Snyk ID
SNYK-JAVA-ORGWEBJARSNPM-479963
Disclosed
18 Nov, 2017
Published
28 Nov, 2017