Arbitrary Command Injection

Affecting org.webjars.npm:macaddress artifact, versions (,0.2.9)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

macaddress Retrieve MAC addresses in Linux, OS X, and Windows.

Affected versions of this package are vulnerable to Arbitrary Command Injection. An attacker could inject arbitrary shell commands if the user input can influence the iface argument.

Remediation

Upgrade macaddress to version 0.2.9 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
ChALkeR
CVE
CVE-2018-13797
CWE
CWE-264
Snyk ID
SNYK-JAVA-ORGWEBJARSNPM-479886
Disclosed
11 May, 2018
Published
13 May, 2018