Information Disclosure

Affecting org.elasticsearch:elasticsearch artifact, versions [7.0.0,7.4.0) || [6.0.0, 6.8.4)

Do your applications use this vulnerable package? Test your applications

Overview

org.elasticsearch:elasticsearch is a Distributed, RESTful Search Engine.

Affected versions of this package are vulnerable to Information Disclosure. An unauthenticated attacker could send a specially crafted request and determine if a username exists in the Elasticsearch native realm.

Remediation

Upgrade org.elasticsearch:elasticsearch to version 7.4.0, 6.8.4 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
  • Exploit maturity
    Unproven
  • Remediation Level
    Official
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:O/RC:R
Credit
Unknown
CVE
CVE-2019-7619
CWE
CWE-200
Snyk ID
SNYK-JAVA-ORGELASTICSEARCH-474622
Disclosed
30 Oct, 2019
Published
30 Oct, 2019