Information Exposure

Affecting org.elasticsearch:elasticsearch artifact, versions [5.6.0, 5.6.12) || [6.0.0, 6.4.1)

Do your applications use this vulnerable package? Test your applications

Overview

org.elasticsearch:elasticsearch is a Distributed, RESTful Search Engine.

Affected versions of this package are vulnerable to Information Exposure when secrets are configured via the API. The Elasticsearch _cluster/settings API, when queried, could leak sensitive configuration information such as passwords, tokens, or usernames. This could allow an authenticated Elasticsearch user to improperly view these details.

Remediation

Upgrade org.elasticsearch:elasticsearch to version 5.6.12, 6.4.1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2018-3831
CWE
CWE-200
Snyk ID
SNYK-JAVA-ORGELASTICSEARCH-460551
Disclosed
19 Sep, 2018
Published
02 Sep, 2019