Access Restriction Bypass

Affecting org.apache.tomcat:tomcat-catalina artifact, versions [7,7.0.10)

Do your applications use this vulnerable package? Test your applications

Overview

org.apache.tomcat:tomcat-catalina Apache Tomcat 7.x before 7.0.10 does not follow ServletSecurity annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests to a web application.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2011-1088
CWE
CWE-284
Snyk ID
SNYK-JAVA-ORGAPACHETOMCAT-30885
Disclosed
10 Jun, 2015
Published
10 Jun, 2015