Cross-site Request Forgery (CSRF)

Affecting io.jenkins.plugins:warnings-ng artifact, versions [,5.1.0)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

io.jenkins.plugins:warnings-ng collects compiler warnings or issues reported by static analysis tools and visualizes the results.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF). A malicious user could reset warning counts for future builds.

Remediation

Upgrade io.jenkins.plugins:warnings-ng to version 5.1.0 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Credit
Daniel Beck
CVE
CVE-2019-10326
CWE
CWE-352
Snyk ID
SNYK-JAVA-IOJENKINSPLUGINS-174857
Disclosed
31 May, 2019
Published
02 Jun, 2019