Timing Attack

Affecting com.vaadin:vaadin-server artifact, versions [0,8.12.3)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Timing Attack by using CSRF.

Remediation

Upgrade com.vaadin:vaadin-server to version 8.12.3 or higher.

References

CVSS Score

4.2
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
Credit
TatuLund
CWE
CWE-208
Snyk ID
SNYK-JAVA-COMVAADIN-1069817
Disclosed
28 Jan, 2021
Published
17 Feb, 2021