Improper Authentication

Affecting github.com/ory/fosite package, versions <0.31.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

github.com/ory/fosite is an OAuth2 & OpenID Connect framework for Go.

Affected versions of this package are vulnerable to Improper Authentication. When using "private_key_jwt" authentication the uniqueness of the jti value is not checked. When using client authentication method "private_key_jwt", OpenId specification says the following about assertion jti: "A unique identifier for the token, which can be used to prevent reuse of the token. These tokens MUST only be used once, unless conditions for reuse were negotiated between the parties". Hydra does not seem to check the uniqueness of this jti value.

Remediation

Upgrade github.com/ory/fosite to version 0.31.0 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
Credit
Unknown
CVE
CVE-2020-15222
CWE
CWE-287
Snyk ID
SNYK-GOLANG-GITHUBCOMORYFOSITE-1012738
Disclosed
25 Sep, 2020
Published
25 Sep, 2020