Improper Authentication

Affecting github.com/hashicorp/vault/sdk/framework package, versions >=1.7.0 <1.7.2 || >=1.6.0 <1.6.5 || <1.5.9

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Improper Authentication. Vault and Vault Enterprise allowed the renewal of nearly-expired token leases and dynamic secret leases (specifically, those within 1 second of their maximum TTL), which caused them to be incorrectly treated as non-expiring during subsequent use.

Remediation

Upgrade github.com/hashicorp/vault/sdk/framework to version 1.7.2, 1.6.5, 1.5.9 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Credit
Unknown
CVE
CVE-2021-32923
CWE
CWE-287
Snyk ID
SNYK-GOLANG-GITHUBCOMHASHICORPVAULTSDKFRAMEWORK-1299902
Disclosed
03 Jun, 2021
Published
04 Jun, 2021