Credentials Management

Affecting subversion package, versions <1.8.10-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream subversion package. See Remediation section below for Debian:9 relevant versions.

Apache Subversion 1.0.0 through 1.7.x before 1.7.17 and 1.8.x before 1.8.10 uses an MD5 hash of the URL and authentication realm to store cached credentials, which makes it easier for remote servers to obtain the credentials via a crafted authentication realm.

Remediation

Upgrade Debian:9 subversion to version 1.8.10-1 or higher.

References

CVSS Score

4.8
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
CVE
CVE-2014-3528
CWE
CWE-255
Snyk ID
SNYK-DEBIAN9-SUBVERSION-344422
Disclosed
19 Aug, 2014
Published
19 Aug, 2014