Use After Free

Affecting sqlite3 package, versions <3.16.2-5+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Use After Free. SQLite 3.32.2 has a use-after-free in resetAccumulator in select.c because the parse tree rewrite for window functions is too late.

Remediation

Upgrade sqlite3 to version or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2020-13871
CWE
CWE-416
Snyk ID
SNYK-DEBIAN9-SQLITE3-571630
Disclosed
06 Jun, 2020
Published
06 Jun, 2020