Arbitrary Code Injection

Affecting sensible-utils package, versions <0.0.9+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

sensible-browser in sensible-utils before 0.0.11 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2017-17512
CWE
CWE-74
Snyk ID
SNYK-DEBIAN9-SENSIBLEUTILS-323135
Disclosed
11 Dec, 2017
Published
11 Dec, 2017