Out-of-Bounds

Affecting procps package, versions <2:3.3.12-3+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

procps-ng before version 3.3.15 is vulnerable to a denial of service in ps via mmap buffer overflow. Inbuilt protection in ps maps a guard page at the end of the overflowed buffer, ensuring that the impact of this flaw is limited to a crash (temporary denial of service).

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2018-1123
CWE
CWE-119 CWE-122
Snyk ID
SNYK-DEBIAN9-PROCPS-309332
Disclosed
23 May, 2018
Published
23 May, 2018