Integer Overflow or Wraparound

Affecting openjpeg2 package, versions <2.1.2-1.1+deb9u4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

An improper computation of p_tx0, p_tx1, p_ty0 and p_ty1 in the function opj_get_encoding_parameters in openjp2/pi.c in OpenJPEG through 2.3.0 can lead to an integer overflow.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2018-20847
CWE
CWE-190
Snyk ID
SNYK-DEBIAN9-OPENJPEG2-451283
Disclosed
26 Jun, 2019
Published
01 Jul, 2019