Integer Overflow or Wraparound

Affecting openjpeg2 package, versions <2.1.2-1.1+deb9u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream openjpeg2 package. See Remediation section below for Debian:9 relevant versions.

In OpenJPEG 2.3.0, there is an integer overflow caused by an out-of-bounds left shift in the opj_j2k_setup_encoder function (openjp2/j2k.c). Remote attackers could leverage this vulnerability to cause a denial of service via a crafted bmp file.

Remediation

Upgrade Debian:9 openjpeg2 to version 2.1.2-1.1+deb9u3 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2018-5785
CWE
CWE-190
Snyk ID
SNYK-DEBIAN9-OPENJPEG2-345954
Disclosed
19 Jan, 2018
Published
19 Jan, 2018