Improper Input Validation

Affecting node-lodash package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream node-lodash package.

Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.

Remediation

There is no fixed version for Debian:9 node-lodash.

References

CVSS Score

9.1
critical severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
CVE
CVE-2019-10744
Snyk ID
SNYK-DEBIAN9-NODELODASH-455506
Disclosed
26 Jul, 2019
Published
26 Jul, 2019