Improper Input Validation

Affecting nghttp2 package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

References

CVSS Score

7.5
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2018-1000168
CWE
CWE-20 CWE-476
Snyk ID
SNYK-DEBIAN9-NGHTTP2-351879
Disclosed
08 May, 2018
Published
08 May, 2018