Improper Data Handling

Affecting mercurial package, versions <3.7.3-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mercurial package. See Remediation section below for Debian:9 relevant versions.

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.

Remediation

Upgrade Debian:9 mercurial to version 3.7.3-1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2016-3630
CWE
CWE-19
Snyk ID
SNYK-DEBIAN9-MERCURIAL-311108
Disclosed
13 Apr, 2016
Published
13 Apr, 2016