Link Following

Affecting mercurial package, versions <4.0-1+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mercurial package. See Remediation section below for Debian:9 relevant versions.

Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository

Remediation

Upgrade Debian:9 mercurial to version 4.0-1+deb9u1 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE
CVE-2017-1000115
CWE
CWE-59
Snyk ID
SNYK-DEBIAN9-MERCURIAL-311076
Disclosed
05 Oct, 2017
Published
05 Oct, 2017