Information Exposure

Affecting mediawiki package, versions <1:1.27.7-1~deb9u7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mediawiki package. See Remediation section below for Debian:9 relevant versions.

In MediaWiki before 1.31.8, 1.32.x and 1.33.x before 1.33.4, and 1.34.x before 1.34.2, private wikis behind a caching server using the img_auth.php image authorization security feature may have had their files cached publicly, so any unauthorized user could view them. This occurs because Cache-Control and Vary headers were mishandled.

Remediation

Upgrade Debian:9 mediawiki to version 1:1.27.7-1~deb9u7 or higher.

References

CVSS Score

3.1
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
CVE
CVE-2020-15005
CWE
CWE-200
Snyk ID
SNYK-DEBIAN9-MEDIAWIKI-573247
Disclosed
24 Jun, 2020
Published
25 Jun, 2020