Improper Input Validation

Affecting mediawiki package, versions <1:1.27.7-1~deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mediawiki package. See Remediation section below for Debian:9 relevant versions.

Wikimedia MediaWiki 1.27.0 through 1.32.1 might allow DoS. Passing invalid titles to the API could cause a DoS by querying the entire watchlist table. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Remediation

Upgrade Debian:9 mediawiki to version 1:1.27.7-1~deb9u1 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2019-12473
Snyk ID
SNYK-DEBIAN9-MEDIAWIKI-349422
Disclosed
10 Jul, 2019
Published
09 Jun, 2019